Em resumo
- CVE-2022-44645 é uma vulnerabilidade ALTO (CVSS 8.8) que afeta org.apache.linkis:linkis, linkis (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 1.9%, maior que 80.1% das vulnerabilidades.
- Correção: atualize para 1.3.1 ou posterior.
Description
In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures new datasource with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users to upgrade the version of Linkis to version 1.3.1.
NVD description
In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures new datasource with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected.
We recommend users to upgrade the version of Linkis to version 1.3.1.
Mais vulnerabilidades de org.apache.linkis:linkis
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free