Tóm tắt nhanh
- CVE-2007-0469 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.3) ảnh hưởng rubygems-update, rubygems (rubyforge).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 4.9%, cao hơn 92.0% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.9.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| rubygems-update RubyGems | < 0.9.1
| 0.9.1
|
| rubygems | = 0.8.11≤ 0.9.0
| Chưa có bản vá |
Mô tả
The extract_files function in installer.rb in RubyGems before 0.9.1 does not check whether files exist before overwriting them, which allows user-assisted remote attackers to overwrite arbitrary files, cause a denial of service, or execute arbitrary code via crafted GEM packages.
Mô tả của NVD
The extract_files function in installer.rb in RubyGems before 0.9.1 does not check whether files exist before overwriting them, which allows user-assisted remote attackers to overwrite arbitrary files, cause a denial of service, or execute arbitrary code via crafted GEM packages.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí