Tóm tắt nhanh
- CVE-2018-17196 là lỗ hổng mức CAO (CVSS 8.8) ảnh hưởng org.apache.kafka:kafka, kafka (apache).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 5.4%, cao hơn 92.7% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.1.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| org.apache.kafka:kafka Maven | ≥ 0.11.0.0, < 2.1.1
| 2.1.1
|
| kafka | ≥ 0.11.0.0, ≤ 2.1.0
| Chưa có bản vá |
Mô tả
In Apache Kafka versions between 0.11.0.0 and 2.1.0, it is possible to manually craft a Produce request which bypasses transaction/idempotent ACL validation. Only authenticated clients with Write permission on the respective topics are able to exploit this vulnerability. Users should upgrade to 2.1.1 or later where this vulnerability has been fixed.
Mô tả của NVD
In Apache Kafka versions between 0.11.0.0 and 2.1.0, it is possible to manually craft a Produce request which bypasses transaction/idempotent ACL validation. Only authenticated clients with Write permission on the respective topics are able to exploit this vulnerability. Users should upgrade to 2.1.1 or later where this vulnerability has been fixed.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí