| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| org.apache.kafka:kafka | ≥ 2.8.0, < 2.8.2≥ 3.0.0, < 3.0.2≥ 3.1.0, < 3.1.2≥ 3.2.0, < 3.2.3 | 2.8.23.0.23.1.23.2.3 |
| kafka | ≥ 2.8.0, < 2.8.2≥ 3.0.0, < 3.0.2≥ 3.1.0, < 3.1.2≥ 3.2.0, < 3.2.3 | 2.8.23.0.23.1.23.2.3 |
A security vulnerability has been identified in Apache Kafka. It affects all releases since 2.8.0. The vulnerability allows malicious unauthenticated clients to allocate large amounts of memory on brokers. This can lead to brokers hitting OutOfMemoryException and causing denial of service. Example scenarios: - Kafka cluster without authentication: Any clients able to establish a network connection to a broker can trigger the issue. - Kafka cluster with SASL authentication: Any clients able to establish a network connection to a broker, without the need for valid SASL credentials, can trigger the issue. - Kafka cluster with TLS authentication: Only clients able to successfully authenticate via TLS can trigger the issue. We advise the users to upgrade the Kafka installations to one of the 3.2.3, 3.1.2, 3.0.2, 2.8.2 versions.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí