Tóm tắt nhanh
- CVE-2021-21408 là lỗ hổng mức CAO (CVSS 8.8) ảnh hưởng smarty/smarty, smarty (smarty).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 2.1%, cao hơn 81.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.0.3, 3.1.43 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| smarty/smarty Packagist | ≥ 4.0.0, < 4.0.3< 3.1.43
| 4.0.33.1.43
|
| smarty | ≥ 4.0.0, < 4.0.3< 3.1.43
| 4.0.33.1.43
|
Mô tả
Impact
Template authors could run restricted static php methods.
Patches
Please upgrade to 3.1.40 or higher.
References
See the documentation on Smarty security features on the static_classes access filter.
For more information
If you have any questions or comments about this advisory please open an issue in the Smarty repo
Mô tả của NVD
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.43 and 4.0.3, template authors could run restricted static php methods. Users should upgrade to version 3.1.43 or 4.0.3 to receive a patch.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí