Tóm tắt nhanh
- CVE-2021-29454 là lỗ hổng mức CAO (CVSS 8.8) ảnh hưởng smarty/smarty, smarty (smarty).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.8%, cao hơn 78.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.0.2, 3.1.42 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| smarty/smarty Packagist | ≥ 4.0.0, < 4.0.2< 3.1.42
| 4.0.23.1.42
|
| smarty | ≥ 4.0.0, < 4.0.2< 3.1.42
| 4.0.23.1.42
|
Mô tả
Impact
Template authors could run arbitrary PHP code by crafting a malicious math string.
If a math string is passed through as user provided data to the math function, external users could run arbitrary PHP code by crafting a malicious math string.
Patches
Please upgrade to 4.0.2 or 3.1.42 or higher.
References
See documentation on Math function.
For more information
If you have any questions or comments about this advisory please open an issue in the Smarty repo
Mô tả của NVD
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.42 and 4.0.2, template authors could run arbitrary PHP code by crafting a malicious math string. If a math string was passed through as user provided data to the math function, external users could run arbitrary PHP code by crafting a malicious math string. Users should upgrade to version 3.1.42 or 4.0.2 to receive a patch.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí