| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| contao/contao | ≥ 4.0.0, < 4.4.56≥ 4.10.0, < 4.11.7≥ 4.5.0, < 4.9.18 | 4.4.564.11.74.9.18 |
| contao/core-bundle | ≥ 4.0.0, < 4.4.56≥ 4.10.0, < 4.11.7≥ 4.5.0, < 4.9.18 | 4.4.564.11.74.9.18 |
| contao | ≥ 4.0.0, < 4.4.56≥ 4.10.0, < 4.11.7≥ 4.5.0, < 4.9.18 | 4.4.564.11.74.9.18 |
It is possible for untrusted users to inject malicious code into HTML attributes in the back end, which will be executed both in the element preview (back end) and on the website (front end).
Installations are only affected if there are untrusted back end users who have the rights to modify HTML fields (e.g. TinyMCE).
Update to Contao 4.4.56, 4.9.18 or 4.11.7
Disable all fields that allow HTML for untrusted back end users or disable the login for these users.
https://contao.org/en/security-advisories/cross-site-scripting-via-html-attributes-in-the-back-end
If you have any questions or comments about this advisory, open an issue in contao/contao.
Thanks to Mikhail Khramenkov and Moritz Vondano for reporting this security issue.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí