Tóm tắt nhanh
- CVE-2022-29221 là lỗ hổng mức CAO (CVSS 8.8) ảnh hưởng smarty/smarty, smarty (smarty).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 4.9%, cao hơn 92.1% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.1.1, 3.1.45 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| smarty/smarty Packagist | ≥ 4.0.0, < 4.1.1< 3.1.45
| 4.1.13.1.45
|
| smarty | ≥ 4.0.0, < 4.1.1< 3.1.45
| 4.1.13.1.45
|
Mô tả
Impact
Template authors could inject php code by choosing a malicous {block} name or {include} file name. Sites that cannot fully trust template authors should update asap.
Patches
Please upgrade to the most recent version of Smarty v3 or v4.
Workarounds
Is there a way for users to fix or remediate the vulnerability without upgrading?
References
Are there any links users can visit to find out more?
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.45 and 4.1.1, template authors could inject php code by choosing a malicious {block} name or {include} file name. Sites that cannot fully trust template authors should upgrade to versions 3.1.45 or 4.1.1 to receive a patch for this issue. There are currently no known workarounds.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí