Tóm tắt nhanh
- CVE-2022-31157 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng packbackbooks/lti-1-3-php-library, lti 1.3 tool library (packback).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.45%, cao hơn 39.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 5.0, 5.0.0 hoặc mới hơn.
Mô tả
Impact
The function used to generate random nonces was not sufficiently cryptographically complex. As a result values may be predictable and tokens may be forgable.
Patches
Users should upgrade to version 5.0 immediately
Workarounds
None.
Mô tả của NVD
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the function used to generate random nonces was not sufficiently cryptographically complex. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
Lỗ hổng khác của packbackbooks/lti-1-3-php-library
Xem tất cả →Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí