Tóm tắt nhanh
- CVE-2024-32474 là lỗ hổng mức TRUNG BÌNH (CVSS 6.5) ảnh hưởng sentry, sentry (sentry).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.43%, cao hơn 37.0% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 24.4.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| sentry PyPI | ≥ 24.3.0, < 24.4.1
| 24.4.1
|
| sentry | ≥ 24.3.0, < 24.4.1
| 24.4.1
|
Mô tả
Impact
When authenticating as a superuser to a self-hosted Sentry instance with a username and password, the password is leaked as cleartext in logs under the event: auth-index.validate_superuser. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser.
Patches
- Self-hosted users on affected versions should upgrade to 24.4.1 or later.
- Sentry SaaS users do not need to take any action. This vulnerability is not applicable to SaaS.
Workarounds
Users can configure the logging level to exclude logs of the INFO level and only generate logs for levels at WARNING or higher. For details on configuring self-hosted Sentry's logging level see our documentation at: https://develop.sentry.dev/config/#logging
References
Mô tả của NVD
Sentry is an error tracking and performance monitoring platform. Prior to 24.4.1, when authenticating as a superuser to Sentry with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Self-hosted users on affected versions should upgrade to 24.4.1 or later. Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or more.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí