Tóm tắt nhanh
- CVE-2025-22146 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.1) ảnh hưởng sentry.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.61%, cao hơn 49.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 25.1.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| sentry PyPI | ≥ 21.12.0, < 25.1.0
| 25.1.0
|
Mô tả
Impact
A critical vulnerability was discovered in the SAML SSO implementation of Sentry. It was reported to us via our private bug bounty program.
The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability.
Patches
- Sentry SaaS: The fix was deployed on Jan 14, 2025.
- Self-Hosted Sentry: If only a single organization is allowed (
SENTRY_SINGLE_ORGANIZATION = True), then no action is needed. Otherwise, users should upgrade to version 25.1.0 or higher.
Workarounds
No known workarounds.
References
Mô tả của NVD
Sentry is a developer-first error tracking and performance monitoring tool. A critical vulnerability was discovered in the SAML SSO implementation of Sentry. It was reported to us via our private bug bounty program. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. The Sentry SaaS fix was deployed on Jan 14, 2025. For self hosted users; if only a single organization is allowed `(SENTRY_SINGLE_ORGANIZATION = True)`, then no action is needed. Otherwise, users should upgrade to version 25.1.0 or higher. There are no known workarounds for this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí