Tóm tắt nhanh
- CVE-2024-45606 là lỗ hổng mức TRUNG BÌNH (CVSS 4.3) ảnh hưởng sentry, sentry (sentry).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.36%, cao hơn 29.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 24.9.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| sentry PyPI | ≥ 23.4.0, < 24.9.0
| 24.9.0
|
| sentry | ≥ 23.4.0, < 24.9.0
| 24.9.0
|
Mô tả
Impact
An authenticated user can mute alert rules from arbitrary organizations and projects given a known given rule ID. The user does not need to be a member of the organization or have permissions on the project.
In our review, we have identified no instances where alerts have been muted by unauthorized parties.
Patches
A patch was issued to ensure authorization checks are properly scoped on requests to mute alert rules. Authenticated users who do not have the necessary permissions are no longer able to mute alerts.
Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 24.9.0 or higher.
Affected Versions
The rule mute feature was generally available as of 23.6.0 but users with early access may have had the feature as of 23.4.0.
Update
As of 2024-10-25 and after additional we've updated the Severity scoring to reduce Privileged Required from Low to None and Integrity from High to Low. Thanks again to @emanuelbeni for the correction on Privileges Required.
References
Mô tả của NVD
Sentry is a developer-first error tracking and performance monitoring platform. An authenticated user can mute alert rules from arbitrary organizations and projects with a know rule ID. The user does not need to be a member of the organization or have permissions on the project. In our review, we have identified no instances where alerts have been muted by unauthorized parties. A patch was issued to ensure authorization checks are properly scoped on requests to mute alert rules. Authenticated users who do not have the necessary permissions are no longer able to mute alerts. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version **24.9.0** or higher. The rule mute feature was generally available as of 23.6.0 but users with early access may have had the feature as of 23.4.0. Affected users are advised to upgrade to version 24.9.0. There are no known workarounds for this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí