Tóm tắt nhanh
- CVE-2024-37899 là lỗ hổng mức CAO (CVSS 8.0) ảnh hưởng org.xwiki.platform:xwiki-platform-oldcore, xwiki (xwiki).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.69%, cao hơn 53.0% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 14.10.21, 15.5.5, 15.10.6, 16.0.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| org.xwiki.platform:xwiki-platform-oldcore Maven | ≥ 13.10.3, < 14.10.21≥ 13.4.7, < 14.10.21≥ 15.0-rc-1, < 15.5.5≥ 15.6-rc-1, < 15.10.6≥ 16.0.0-rc-1, < 16.0.0
| 14.10.2115.5.515.10.616.0.0
|
| xwiki | = 13.4.7= 13.5= 16.0.0≥ 13.10.3, < 14.10.21≥ 15.0, < 15.5.5≥ 15.6, < 15.10.6
| 14.10.2115.5.515.10.6
|
Mô tả
Impact
When an admin disables a user account, the user's profile is executed with the admin's rights. This allows a user to place malicious code in the user profile before getting an admin to disable the user account.
To reproduce, as a user without script nor programming rights, edit the about section of your user profile and add {{groovy}}services.logging.getLogger("attacker").error("Hello from Groovy!"){{/groovy}}.
As an admin, go to the user profile and click the "Disable this account" button.
Then, reload the page. If the logs show attacker - Hello from Groovy! then the instance is vulnerable.
Patches
This has been patched in XWiki 14.10.21, 15.5.5, 15.10.6 and 16.0.0.
Workarounds
We're not aware of any workaround except upgrading.
References
Mô tả của NVD
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. When an admin disables a user account, the user's profile is executed with the admin's rights. This allows a user to place malicious code in the user profile before getting an admin to disable the user account. To reproduce, as a user without script nor programming rights, edit the about section of your user profile and add `{{groovy}}services.logging.getLogger("attacker").error("Hello from Groovy!"){{/groovy}}`.
As an admin, go to the user profile and click the "Disable this account" button. Then, reload the page. If the logs show `attacker - Hello from Groovy!` then the instance is vulnerable. This has been patched in XWiki 14.10.21, 15.5.5, 15.10.6 and 16.0.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
### Workarounds
We're not aware of any workaround except upgrading.
### References
* https://jira.xwiki.org/browse/XWIKI-21611
* https://github.com/xwiki/xwiki-platform/commit/f89c8f47fad6e5cc7e68c69a7e0acde07f5eed5a
Lỗ hổng khác của org.xwiki.platform:xwiki-platform-oldcore
Xem tất cả →Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí