| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| cgi | ≥ 0.3.6, < 0.3.7≥ 0.4.0, < 0.4.2< 0.3.5.1 | 0.3.70.4.20.3.5.1 |
| cgi | = 0.3.6≥ 0.4.0, < 0.4.2< 0.3.5.1 | 0.4.20.3.5.1 |
There is a possibility for DoS by in the cgi gem. This vulnerability has been assigned the CVE identifier CVE-2025-27219. We recommend upgrading the cgi gem.
CGI::Cookie.parse took super-linear time to parse a cookie string in some cases. Feeding a maliciously crafted cookie string into the method could lead to a Denial of Service.
Please update CGI gem to version 0.3.5.1, 0.3.7, 0.4.2 or later.
cgi gem versions <= 0.3.5, 0.3.6, 0.4.0 and 0.4.1.
Thanks to lio346 for discovering this issue. Also thanks to mame for fixing this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí