| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| cgi | ≥ 0.3.6, < 0.3.7≥ 0.4.0, < 0.4.2< 0.3.5.1 | 0.3.70.4.20.3.5.1 |
| cgi | = 0.3.6≥ 0.4.0, < 0.4.2< 0.3.5.1 | 0.4.20.3.5.1 |
There is a possibility for Regular expression Denial of Service (ReDoS) by in the cgi gem. This vulnerability has been assigned the CVE identifier CVE-2025-27220. We recommend upgrading the cgi gem.
The regular expression used in CGI::Util#escapeElement is vulnerable to ReDoS. The crafted input could lead to a high CPU consumption.
This vulnerability only affects Ruby 3.1 and 3.2. If you are using these versions, please update CGI gem to version 0.3.5.1, 0.3.7, 0.4.2 or later.
cgi gem versions <= 0.3.5, 0.3.6, 0.4.0 and 0.4.1.
Thanks to svalkanov for discovering this issue. Also thanks to nobu for fixing this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí