| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.0-M1, < 10.1.58≥ 11.0.0-M1, < 11.0.25≥ 7.0.0, ≤ 7.0.109≥ 8.5.0, ≤ 8.5.100≥ 9.0.0-M1, < 9.0.121 | 10.1.5811.0.259.0.121 |
| org.apache.tomcat:tomcat | ≥ 10.1.0-M1, < 10.1.58≥ 11.0.0-M1, < 11.0.25≥ 7.0.0, ≤ 7.0.109≥ 8.5.0, ≤ 8.5.100≥ 9.0.0-M1, < 9.0.121 | 10.1.5811.0.259.0.121 |
| org.apache.tomcat:tomcat-catalina | ≥ 10.1.0-M1, < 10.1.58≥ 11.0.0-M1, < 11.0.25≥ 7.0.0, ≤ 7.0.109≥ 8.5.0, ≤ 8.5.100≥ 9.0.0-M1, < 9.0.121 | 10.1.5811.0.259.0.121 |
| tomcat | ≥ 10.1.0, < 10.1.58≥ 11.0.0, < 11.0.25≥ 7.0.0, ≤ 7.0.109≥ 8.5.0, < 9.0.121 | 10.1.5811.0.259.0.121 |
Improper Access Control, Incorrect Authorization vulnerability in Apache Tomcat leads to security constraint bypass if a constraint for a longer path is specified before a more restrictive constraint for a shorter sub-path.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109.
Users are recommended to upgrade to version 11.0.25, 10.1.58, 9.0.121, which fixes the issue.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí