要点
- CVE-2026-33435 是影响 weblate, weblate (weblate) 的高危 (CVSS 8.0)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.71%,高于 53.5% 的漏洞。
- 修复:升级到 5.17 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 5.17
| 5.17
|
| weblate | < 5.17
| 5.17
|
Description
Impact
The project backup didn't filter Git and Mercurial configuration files and this could lead to remote code execution under certain circumstances.
Patches
Workarounds
The project backup is only accessible to users who can create projects. Restricting access to this limits scope of the vulnerability.
References
This issue was reported by ggamno via HackerOne.
NVD description
Weblate is a web based localization tool. In versions prior to 5.17, the project backup didn't filter Git and Mercurial configuration files which could lead to remote code execution under certain circumstances. This issue has been fixed in version 5.17. If developers are unable to update immediately, they can limit the scope of the vulnerability by restricting access to the project backup, as it is only accessible to users who can create projects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free