In short
- CVE-2013-1629 is a MEDIUM (CVSS 6.8) vulnerability affecting pip, pip (pypa).
- Chance of exploitation in the next 30 days (EPSS): 6.2%, higher than 93.5% of all vulnerabilities.
- Fix: update to 1.3 or later.
| Package | Affected versions | Patched versions |
|---|
| pip PyPI | < 1.3
| 1.3
|
| pip | < 1.3
| 1.3
|
Description
pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a "pip install" operation.
NVD description
pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a "pip install" operation.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free