In short
- CVE-2016-10149 is a HIGH (CVSS 7.5) vulnerability affecting pysaml2, pysaml2 (pysaml2 project).
- Chance of exploitation in the next 30 days (EPSS): 5.0%, higher than 92.3% of all vulnerabilities.
- Fix: update to 4.5.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pysaml2 PyPI | < 4.5.0
| 4.5.0
|
| pysaml2 | ≤ 4.4.0
| No fix yet |
Description
XML External Entity (XXE) vulnerability in PySAML2 4.4.0 and earlier allows remote attackers to read arbitrary files via a crafted SAML XML request or response.
NVD description
XML External Entity (XXE) vulnerability in PySAML2 4.4.0 and earlier allows remote attackers to read arbitrary files via a crafted SAML XML request or response.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free