In short
- CVE-2020-5390 is a HIGH (CVSS 7.5) vulnerability affecting pysaml2, pysaml2 (pysaml2 project).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 69.1% of all vulnerabilities.
- Fix: update to 5.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pysaml2 PyPI | < 5.0.0
| 5.0.0
|
| pysaml2 | < 5.0.0
| 5.0.0
|
Description
PySAML2 before 5.0.0 does not check that the signature in a SAML document is enveloped and thus signature wrapping is effective, i.e., it is affected by XML Signature Wrapping (XSW). The signature information and the node/object that is signed can be in different places and thus the signature verification will succeed, but the wrong data will be used. This specifically affects the verification of assertions that have been signed.
NVD description
PySAML2 before 5.0.0 does not check that the signature in a SAML document is enveloped and thus signature wrapping is effective, i.e., it is affected by XML Signature Wrapping (XSW). The signature information and the node/object that is signed can be in different places and thus the signature verification will succeed, but the wrong data will be used. This specifically affects the verification of assertion that have been signed.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free