In short
- CVE-2017-1000246 is a MEDIUM (CVSS 5.3) vulnerability affecting pysaml2, pysaml2 (pysaml2 project).
- Chance of exploitation in the next 30 days (EPSS): 0.89%, higher than 59.4% of all vulnerabilities.
- Fix: update to 4.6.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pysaml2 PyPI | < 4.6.0
| 4.6.0
|
| pysaml2 | < 4.6.0
| 4.6.0
|
Description
Python package pysaml2 version 4.5.0 and earlier reuses the initialization vector across encryptions in the IDP server, resulting in weak encryption of data.
NVD description
Python package pysaml2 version 4.4.0 and earlier reuses the initialization vector across encryptions in the IDP server, resulting in weak encryption of data.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free