In short
- CVE-2017-1000433 is a HIGH (CVSS 8.1) vulnerability affecting pysaml2, pysaml2 (pysaml2 project).
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 85.0% of all vulnerabilities.
- Fix: update to 4.5.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pysaml2 PyPI | < 4.5.0
| 4.5.0
|
| pysaml2 | ≤ 4.4.0
| No fix yet |
Description
pysaml2 version 4.4.0 and older accept any password when run with python optimizations enabled. This allows attackers to log in as any user without knowing their password.
NVD description
pysaml2 version 4.4.0 and older accept any password when run with python optimizations enabled. This allows attackers to log in as any user without knowing their password.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free