In short
- CVE-2019-10773 is a HIGH (CVSS 7.8) vulnerability affecting yarn (yarnpkg), yarn.
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.6% of all vulnerabilities.
- Fix: update to 1.21.1, 1.22.0 or later.
| Package | Affected versions | Patched versions |
|---|
| yarn | < 1.21.1
| 1.21.1
|
| yarn npm | < 1.22.0
| 1.22.0
|
Description
In Yarn before 1.21.1, the package install functionality can be abused to generate arbitrary symlinks on the host filesystem by using specially crafted "bin" keys. Existing files could be overwritten depending on the current user permission set.
NVD description
In Yarn before 1.21.1, the package install functionality can be abused to generate arbitrary symlinks on the host filesystem by using specially crafted "bin" keys. Existing files could be overwritten depending on the current user permission set.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free