In short
- CVE-2019-15608 is a MEDIUM (CVSS 5.9) vulnerability affecting yarn (yarnpkg), yarn.
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 79.0% of all vulnerabilities.
- Fix: update to 1.19.0 or later.
| Package | Affected versions | Patched versions |
|---|
| yarn | < 1.19.0
| 1.19.0
|
| yarn npm | < 1.19.0
| 1.19.0
|
Description
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack. This issue is fixed in 1.19.0.
NVD description
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free