In short
- CVE-2021-4435 is a HIGH (CVSS 7.8) vulnerability affecting yarn (yarnpkg), yarn.
- Chance of exploitation in the next 30 days (EPSS): 0.30%, higher than 22.9% of all vulnerabilities.
- Fix: update to 1.22.13 or later.
| Package | Affected versions | Patched versions |
|---|
| yarn | < 1.22.13
| 1.22.13
|
| yarn npm | < 1.22.13
| 1.22.13
|
Description
An untrusted search path vulnerability was found in Yarn. When a victim runs certain Yarn commands in a directory with attacker-controlled content, malicious commands could be executed in unexpected ways.
NVD description
An untrusted search path vulnerability was found in Yarn. When a victim runs certain Yarn commands in a directory with attacker-controlled content, malicious commands could be executed in unexpected ways.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free