In short
- CVE-2020-8131 is a HIGH (CVSS 7.5) vulnerability affecting yarn (yarnpkg), yarn.
- Chance of exploitation in the next 30 days (EPSS): 5.2%, higher than 92.5% of all vulnerabilities.
- Fix: update to 1.22.0 or later.
| Package | Affected versions | Patched versions |
|---|
| yarn | ≤ 1.21.1
| No fix yet |
| yarn npm | < 1.22.0
| 1.22.0
|
Description
Arbitrary filesystem write vulnerability in Yarn 1.21.1 and earlier allows attackers to write to any path on the filesystem and potentially lead to arbitrary code execution by forcing the user to install a malicious package.
NVD description
Arbitrary filesystem write vulnerability in Yarn before 1.22.0 allows attackers to write to any path on the filesystem and potentially lead to arbitrary code execution by forcing the user to install a malicious package.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free