In short
- CVE-2021-20717 is a MEDIUM (CVSS 6.1) vulnerability affecting ec-cube/ec-cube, ec-cube (ec-cube).
- Chance of exploitation in the next 30 days (EPSS): 2.3%, higher than 83.4% of all vulnerabilities.
- Fix: update to 4.0.5 or later.
| Package | Affected versions | Patched versions |
|---|
| ec-cube/ec-cube Packagist | ≥ 4.0.0, ≤ 4.0.5
| No fix yet |
| ec-cube | ≥ 4.0.0, < 4.0.5
| 4.0.5
|
Description
Cross-site scripting vulnerability in EC-CUBE 4.0.0 to 4.0.5 allows a remote attacker to inject a specially crafted script in the specific input field of the EC web site which is created using EC-CUBE. As a result, it may lead to an arbitrary script execution on the administrator's web browser.
NVD description
Cross-site scripting vulnerability in EC-CUBE 4.0.0 to 4.0.5 allows a remote attacker to inject a specially crafted script in the specific input field of the EC web site which is created using EC-CUBE. As a result, it may lead to an arbitrary script execution on the administrator's web browser.
More vulnerabilities in ec-cube/ec-cube
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free