In short
- CVE-2022-23110 is a MEDIUM (CVSS 4.8) vulnerability affecting org.jenkins-ci.plugins:publish-over-ssh, publish over ssh (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.82%, higher than 57.2% of all vulnerabilities.
- Fix: update to 1.23 or later.
Description
Jenkins Publish Over SSH Plugin 1.22 and earlier does not escape the SSH server name, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Overall/Administer permission.
NVD description
Jenkins Publish Over SSH Plugin 1.22 and earlier does not escape the SSH server name, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Overall/Administer permission.
More vulnerabilities in org.jenkins-ci.plugins:publish-over-ssh
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free