In short
- CVE-2022-23113 is a MEDIUM (CVSS 4.3) vulnerability affecting org.jenkins-ci.plugins:publish-over-ssh, publish over ssh (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.3% of all vulnerabilities.
- Fix: update to 1.23 or later.
Description
Jenkins Publish Over SSH Plugin 1.22 and earlier performs a validation of the file name specifying whether it is present or not, resulting in a path traversal vulnerability allowing attackers with Item/Configure permission to discover the name of the Jenkins controller files.
NVD description
Jenkins Publish Over SSH Plugin 1.22 and earlier performs a validation of the file name specifying whether it is present or not, resulting in a path traversal vulnerability allowing attackers with Item/Configure permission to discover the name of the Jenkins controller files.
More vulnerabilities in org.jenkins-ci.plugins:publish-over-ssh
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free