In short
- CVE-2022-23114 is a LOW (CVSS 3.3) vulnerability affecting org.jenkins-ci.plugins:publish-over-ssh, publish over ssh (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.31%, higher than 23.6% of all vulnerabilities.
- Fix: update to 1.23 or later.
Description
Jenkins Publish Over SSH Plugin 1.22 and earlier stores password unencrypted in its global configuration file on the Jenkins controller where it can be viewed by users with access to the Jenkins controller file system.
NVD description
Jenkins Publish Over SSH Plugin 1.22 and earlier stores password unencrypted in its global configuration file on the Jenkins controller where it can be viewed by users with access to the Jenkins controller file system.
More vulnerabilities in org.jenkins-ci.plugins:publish-over-ssh
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free