In short
- CVE-2022-23112 is a MEDIUM (CVSS 6.5) vulnerability affecting org.jenkins-ci.plugins:publish-over-ssh, publish over ssh (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.85%, higher than 58.4% of all vulnerabilities.
- Fix: update to 1.24 or later.
Description
A missing permission check in Jenkins Publish Over SSH Plugin 1.22 and earlier allows attackers with Overall/Read access to connect to an attacker-specified SSH server using attacker-specified credentials.
NVD description
A missing permission check in Jenkins Publish Over SSH Plugin 1.22 and earlier allows attackers with Overall/Read access to connect to an attacker-specified SSH server using attacker-specified credentials.
More vulnerabilities in org.jenkins-ci.plugins:publish-over-ssh
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free