In short
- CVE-2023-5752 is a LOW (CVSS 3.3) vulnerability affecting pip, pip (pypa).
- Chance of exploitation in the next 30 days (EPSS): 0.50%, higher than 43.0% of all vulnerabilities.
- Fix: update to 23.3 or later.
| Package | Affected versions | Patched versions |
|---|
| pip PyPI | < 23.3
| 23.3
|
| pip | < 23.3
| 23.3
|
Description
When installing a package from a Mercurial VCS URL, e.g. pip install hg+..., with pip prior to v23.3, the specified Mercurial revision could be used to inject arbitrary configuration options to the hg clone call (e.g. --config). Controlling the Mercurial configuration can modify how and which repository is installed. This vulnerability does not affect users who aren't installing from Mercurial.
NVD description
When installing a package from a Mercurial VCS URL (ie "pip install
hg+...") with pip prior to v23.3, the specified Mercurial revision could
be used to inject arbitrary configuration options to the "hg clone"
call (ie "--config"). Controlling the Mercurial configuration can modify
how and which repository is installed. This vulnerability does not
affect users who aren't installing from Mercurial.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free