In short
- CVE-2024-21508 is a CRITICAL (CVSS 9.8) vulnerability affecting mysql2.
- Chance of exploitation in the next 30 days (EPSS): 2.6%, higher than 85.1% of all vulnerabilities.
- Fix: update to 3.9.4 or later.
| Package | Affected versions | Patched versions |
|---|
| mysql2 npm | < 3.9.4
| 3.9.4
|
Description
Versions of the package mysql2 before 3.9.4 are vulnerable to Remote Code Execution (RCE) via the readCodeFor function due to improper validation of the supportBigNumbers and bigNumberStrings values.
NVD description
Versions of the package mysql2 before 3.9.4 are vulnerable to Remote Code Execution (RCE) via the readCodeFor function due to improper validation of the supportBigNumbers and bigNumberStrings values.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free