In short
- CVE-2024-21512 is a HIGH (CVSS 8.2) vulnerability affecting mysql2.
- Chance of exploitation in the next 30 days (EPSS): 3.1%, higher than 88.0% of all vulnerabilities.
- Fix: update to 3.9.8 or later.
| Package | Affected versions | Patched versions |
|---|
| mysql2 npm | < 3.9.8
| 3.9.8
|
Description
Versions of the package mysql2 before 3.9.8 are vulnerable to Prototype Pollution due to improper user input sanitization passed to fields and tables when using nestTables.
NVD description
Versions of the package mysql2 before 3.9.8 are vulnerable to Prototype Pollution due to improper user input sanitization passed to fields and tables when using nestTables.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free