In short
- CVE-2024-21511 is a CRITICAL (CVSS 9.8) vulnerability affecting mysql2.
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 64.0% of all vulnerabilities.
- Fix: update to 3.9.7 or later.
| Package | Affected versions | Patched versions |
|---|
| mysql2 npm | < 3.9.7
| 3.9.7
|
Description
Versions of the package mysql2 before 3.9.7 are vulnerable to Arbitrary Code Injection due to improper sanitization of the timezone parameter in the readCodeFor function by calling a native MySQL Server date/time function.
NVD description
Versions of the package mysql2 before 3.9.7 are vulnerable to Arbitrary Code Injection due to improper sanitization of the timezone parameter in the readCodeFor function by calling a native MySQL Server date/time function.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free