In short
- CVE-2024-21547 is a HIGH (CVSS 7.5) vulnerability affecting spatie/browsershot.
- Chance of exploitation in the next 30 days (EPSS): 0.95%, higher than 61.2% of all vulnerabilities.
- Fix: update to 5.0.2 or later.
Description
Versions of the package spatie/browsershot before 5.0.2 are vulnerable to Directory Traversal due to URI normalisation in the browser where the file:// check can be bypassed with file:\. An attacker could read any file on the server by exploiting the normalization of \ into /.
NVD description
Versions of the package spatie/browsershot before 5.0.2 are vulnerable to Directory Traversal due to URI normalisation in the browser where the file:// check can be bypassed with file:\\. An attacker could read any file on the server by exploiting the normalization of \ into /.
More vulnerabilities in spatie/browsershot
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free