In short
- CVE-2025-1022 is a HIGH (CVSS 8.2) vulnerability affecting spatie/browsershot.
- Chance of exploitation in the next 30 days (EPSS): 0.46%, higher than 40.3% of all vulnerabilities.
- Fix: update to 5.0.5 or later.
Description
Versions of the package spatie/browsershot before 5.0.5 are vulnerable to Improper Input Validation in the setHtml function, invoked by Browsershot::html(), which can be bypassed by omitting the slashes in the file URI (e.g., file:../../../../etc/passwd). This is due to missing validations of the user input that should be blocking file URI schemes (e.g., file:// and file:/) in the HTML content.
NVD description
Versions of the package spatie/browsershot before 5.0.5 are vulnerable to Improper Input Validation in the setHtml function, invoked by Browsershot::html(), which can be bypassed by omitting the slashes in the file URI (e.g., file:../../../../etc/passwd). This is due to missing validations of the user input that should be blocking file URI schemes (e.g., file:// and file:/) in the HTML content.
**Note:** Further analysis has identified additional proof-of-concept exploits leveraging the vulnerable function. Developers using this package should ensure proper input validation to mitigate potential risks, as the issue remains unaddressed.
More vulnerabilities in spatie/browsershot
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free