In short
- CVE-2025-1026 is a HIGH (CVSS 8.6) vulnerability affecting spatie/browsershot.
- Chance of exploitation in the next 30 days (EPSS): 0.55%, higher than 46.0% of all vulnerabilities.
- Fix: update to 5.0.5 or later.
Description
Versions of the package spatie/browsershot before 5.0.5 are vulnerable to Improper Input Validation due to improper URL validation through the setUrl method, which results in a Local File Inclusion allowing the attacker to read sensitive files.
Note:
This is a bypass of the fix for CVE-2024-21549.
NVD description
Versions of the package spatie/browsershot before 5.0.5 are vulnerable to Improper Input Validation due to improper URL validation through the setUrl method, which results in a Local File Inclusion allowing the attacker to read sensitive files.
**Note:**
This is a bypass of the fix for [CVE-2024-21549](https://security.snyk.io/vuln/SNYK-PHP-SPATIEBROWSERSHOT-8533023).
More vulnerabilities in spatie/browsershot
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free