In short
- CVE-2024-21549 is a HIGH (CVSS 8.6) vulnerability affecting spatie/browsershot.
- Chance of exploitation in the next 30 days (EPSS): 0.61%, higher than 49.1% of all vulnerabilities.
- Fix: update to 5.0.3 or later.
Description
Versions of the package spatie/browsershot before 5.0.3 are vulnerable to Improper Input Validation due to improper URL validation through the setUrl method. An attacker can exploit this vulnerability by utilizing view-source:file://, which allows for arbitrary file reading on a local file.
Note:
This is a bypass of the fix for CVE-2024-21544.
NVD description
Versions of the package spatie/browsershot before 5.0.3 are vulnerable to Improper Input Validation due to improper URL validation in the setUrl method. An attacker can exploit this vulnerability by utilizing view-source:file://, which allows for arbitrary file reading on a local file.
**Note:**
This is a bypass of the fix for [CVE-2024-21544](https://security.snyk.io/vuln/SNYK-PHP-SPATIEBROWSERSHOT-8496745).
More vulnerabilities in spatie/browsershot
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free