In short
- CVE-2024-3098 is a CRITICAL (CVSS 9.8) vulnerability affecting llama-index-core.
- Chance of exploitation in the next 30 days (EPSS): 0.96%, higher than 61.5% of all vulnerabilities.
- Fix: update to 0.10.24 or later.
Description
A vulnerability was identified in the exec_utils class of the llama_index package, specifically within the safe_eval function, allowing for prompt injection leading to arbitrary code execution. This issue arises due to insufficient validation of input, which can be exploited to bypass method restrictions and execute unauthorized code. The vulnerability is a bypass of the previously addressed CVE-2023-39662, demonstrated through a proof of concept that creates a file on the system by exploiting the flaw.
NVD description
A vulnerability was identified in the `exec_utils` class of the `llama_index` package, specifically within the `safe_eval` function, allowing for prompt injection leading to arbitrary code execution. This issue arises due to insufficient validation of input, which can be exploited to bypass method restrictions and execute unauthorized code. The vulnerability is a bypass of the previously addressed CVE-2023-39662, demonstrated through a proof of concept that creates a file on the system by exploiting the flaw.
More vulnerabilities in llama-index-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free