In short
- CVE-2024-33883 is a MEDIUM (CVSS 4.0) vulnerability affecting ejs.
- Chance of exploitation in the next 30 days (EPSS): 0.61%, higher than 49.4% of all vulnerabilities.
- Fix: update to 3.1.10 or later.
| Package | Affected versions | Patched versions |
|---|
| ejs npm | < 3.1.10
| 3.1.10
|
Description
The ejs (aka Embedded JavaScript templates) package before 3.1.10 for Node.js lacks certain pollution protection.
NVD description
The ejs (aka Embedded JavaScript templates) package before 3.1.10 for Node.js lacks certain pollution protection.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free