In short
- CVE-2024-3653 is a MEDIUM (CVSS 5.3) vulnerability affecting io.undertow:undertow-core.
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.3% of all vulnerabilities.
- Fix: update to 2.3.15.Final, 2.2.34.Final or later.
| Package | Affected versions | Patched versions |
|---|
| io.undertow:undertow-core Maven | ≥ 2.3.0.Alpha1, < 2.3.15.Final< 2.2.34.Final
| 2.3.15.Final2.2.34.Final
|
Description
A vulnerability was found in Undertow. This issue requires enabling the learning-push handler in the server's config, which is disabled by default, leaving the maxAge config in the handler unconfigured. The default is -1, which makes the handler vulnerable. If someone overwrites that config, the server is not subject to the attack. The attacker needs to be able to reach the server with a normal HTTP request.
NVD description
A vulnerability was found in Undertow. This issue requires enabling the learning-push handler in the server's config, which is disabled by default, leaving the maxAge config in the handler unconfigured. The default is -1, which makes the handler vulnerable. If someone overwrites that config, the server is not subject to the attack. The attacker needs to be able to reach the server with a normal HTTP request.
More vulnerabilities in io.undertow:undertow-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free