In short
- CVE-2024-6162 is a HIGH (CVSS 7.5) vulnerability affecting io.undertow:undertow-core.
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.2% of all vulnerabilities.
- Fix: update to 2.3.14.Final, 2.2.33.Final or later.
| Package | Affected versions | Patched versions |
|---|
| io.undertow:undertow-core Maven | ≥ 2.3.0.Alpha1, < 2.3.14.Final< 2.2.33.Final
| 2.3.14.Final2.2.33.Final
|
Description
A vulnerability was found in Undertow, where URL-encoded request paths can be mishandled during concurrent requests on the AJP listener. This issue arises because the same buffer is used to decode the paths for multiple requests simultaneously, leading to incorrect path information being processed. As a result, the server may attempt to access the wrong path, causing errors such as "404 Not Found" or other application failures. This flaw can potentially lead to a denial of service, as legitimate resources become inaccessible due to the path mix-up.
NVD description
A vulnerability was found in Undertow, where URL-encoded request paths can be mishandled during concurrent requests on the AJP listener. This issue arises because the same buffer is used to decode the paths for multiple requests simultaneously, leading to incorrect path information being processed. As a result, the server may attempt to access the wrong path, causing errors such as "404 Not Found" or other application failures. This flaw can potentially lead to a denial of service, as legitimate resources become inaccessible due to the path mix-up.
More vulnerabilities in io.undertow:undertow-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free