En resumen
- CVE-2022-39944 es una vulnerabilidad ALTO (CVSS 8.8) que afecta a org.apache.linkis:linkis, linkis (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.2%, mayor que el 82.9% de las vulnerabilidades.
- Solución: actualizar a 1.3.0 o posterior.
Description
In Apache Linkis <=1.2.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures a JDBC EC with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. This issue is patched in version 1.3.0, and users are recommended to upgrade.
NVD description
In Apache Linkis <=1.2.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures a JDBC EC with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.2.0 will be affected, We recommend users to update to 1.3.0.
Más vulnerabilidades de org.apache.linkis:linkis
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free