En resumen
- CVE-2022-44644 es una vulnerabilidad MEDIO (CVSS 6.5) que afecta a org.apache.linkis:linkis, linkis (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.2%, mayor que el 67.3% de las vulnerabilidades.
- Solución: actualizar a 1.3.1 o posterior.
Description
In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, an authenticated attacker could read arbitrary local file by connecting a rogue mysql server, By adding allowLoadLocalInfile to true in the jdbc parameter. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.1
NVD description
In Apache Linkis <=1.3.0 when used with the MySQL Connector/J in the data source module, an authenticated attacker could read arbitrary local files by connecting a rogue MySQL server, By adding allowLoadLocalInfile to true in the JDBC parameter. Therefore, the parameters in the JDBC URL should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected.
We recommend users upgrade the version of Linkis to version 1.3.1
Más vulnerabilidades de org.apache.linkis:linkis
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free