En bref
- CVE-2023-25170 est une vulnérabilité ÉLEVÉE (CVSS 8.8) touchant prestashop/prestashop, prestashop (prestashop).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.22%, plus élevée que 12.3% des vulnérabilités.
- Correctif : mettre à jour vers 8.0.1 ou plus récent.
Description
Impact
When authenticating users PrestaShop preserves session attributes. Because this does not clear CSRF tokens upon login, this might enables same-site attackers to bypass the CSRF protection mechanism by performing an attack similar to a session-fixation.
Patches
The problem is fixed in version 8.0.1
NVD description
PrestaShop is an open source e-commerce web application that, prior to version 8.0.1, is vulnerable to cross-site request forgery (CSRF). When authenticating users, PrestaShop preserves session attributes. Because this does not clear CSRF tokens upon login, this might enable same-site attackers to bypass the CSRF protection mechanism by performing an attack similar to a session-fixation. The problem is fixed in version 8.0.1.
Autres vulnérabilités de prestashop/prestashop
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free