| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| indico | ≥ 2.2.0, < 2.2.3< 2.1.10 | 2.2.32.1.10 |
An external audit of the Indico codebase has discovered a vulnerability in Indico's LaTeX sanitization code, which could have malicious users to run unsafe LaTeX commands on the server. Such commands allowed for example to read local files (e.g. indico.conf).
As far as we know it is not possible to write files or execute code using this vulnerability.
You need to update to Indico 2.2.3 as soon as possible. We also released Indico 2.1.10 in case you cannot update to 2.2 for some reason. See https://docs.getindico.io/en/stable/installation/upgrade/ for instructions on how to update.
Setting XELATEX_PATH = None in indico.conf will result in an error when building a PDF, but without being able to run xelatex, the vulnerability cannot be abused.
If you have any questions or comments about this advisory:
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン