| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.0-M1, < 10.1.16≥ 11.0.0-M1, < 11.0.0-M11≥ 8.5.0, < 8.5.96≥ 9.0.0-M1, < 9.0.83 | 10.1.1611.0.0-M118.5.969.0.83 |
| org.apache.tomcat:tomcat-catalina | ≥ 10.1.0-M1, < 10.1.16≥ 11.0.0-M1, < 11.0.0-M11≥ 8.5.0, < 8.5.96≥ 9.0.0-M1, < 9.0.83 | 10.1.1611.0.0-M118.5.969.0.83 |
| org.apache.tomcat:tomcat-coyote | ≥ 11.0.0-M1, < 11.0.0-M11 | 11.0.0-M11 |
| tomcat | = 11.0.0≥ 10.1.0, < 10.1.16≥ 8.5.0, < 8.5.96≥ 9.0.0, < 9.0.83 | 10.1.168.5.969.0.83 |
Improper Input Validation vulnerability in Apache Tomcat. Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82, and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí