Tóm tắt nhanh
- CVE-2025-48951 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.3) ảnh hưởng auth0/auth0-php.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.75%, cao hơn 55.0% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 8.3.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| auth0/auth0-php Packagist | ≥ 8.0.0-BETA3, < 8.3.1
| 8.3.1
|
Mô tả
Overview
The Auth0 PHP SDK contains a vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data.
Am I Affected?
You are affected by this vulnerability if you meet the following preconditions:
- Applications using the Auth0-PHP SDK, versions between 8.0.0-BETA3 to 8.3.0.
- Applications using the following SDKs that rely on the Auth0-PHP SDK versions between 8.0.0-BETA3 to 8.3.0:
a. Auth0/symfony,
b. Auth0/laravel-auth0,
c. Auth0/wordpress.
Fix
Upgrade Auth0/Auth0-PHP to 8.3.1.
Acknowledgement
Okta would like to thank Andreas Forsblom for discovering this vulnerability.
Mô tả của NVD
Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. Versions 8.0.0-BETA3 prior to 8.3.1 contain a vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Applications using the Auth0-PHP SDK are affected, as are applications using the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs, because those SDKsrely on the Auth0-PHP SDK versions from 8.0.0-BETA3 until 8.14.0. Version 8.3.1 contains a patch for the issue.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí