Tóm tắt nhanh
- CVE-2025-68129 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng auth0/auth0-php, auth0-php (auth0), laravel-auth0 (auth0).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.43%, cao hơn 36.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 8.18.0, 7.20.0, 5.6.0, 5.5.0 hoặc mới hơn.
Mô tả
Description
In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens.
Affected product and versions
Projects are affected if they meet the following preconditions:
- Applications using the Auth0-PHP SDK, versions between v8.0.0 and v8.17.0, or
- Applications using the following SDKs that rely on the Auth0-PHP SDK versions between v8.0.0 and v8.17.0:
- a. Auth0/symfony,
- b. Auth0/laravel-auth0,
- c. Auth0/wordpress.
Resolution
Upgrade Auth0/Auth0-PHP to version 8.18.0 or greater.
Acknowledgement
Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.
Mô tả của NVD
Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. Projects are affected if they use Auth0-PHP SDK versions between v8.0.0 and v8.17.0, or applications using the following SDKs that rely on the Auth0-PHP SDK versions between v8.0.0 and v8.17.0: Auth0/symfony versions between 5.0.0 and 5.5.0, Auth0/laravel-auth0 versions between 7.0.0 and 7.19.0, and/or Auth0/wordpress plugin versions between 5.0.0-BETA0 and 5.4.0. Auth0/Auth0-PHP version 8.18.0 contains a patch for the issue.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí